Hỏi đáp

Định Tuyến Tĩnh Là Gì

– Định tuyến là quá trình mà router thực hiện để chuyển gói dữ liệu tới mạng đích. Router dựa vào địa chỉ IP đích của gói tin để chuyển gói ra những Interface theo đúng hướng tới đích cuối cùng. (Mời những khách du lịch xem lại bài viết: Định truyến trên Router)

– Đối với định tuyến tĩnh, những thông tin về đường đi là do người quản trị mạng chỉ định cho Router.

khách du lịch đang xem: định tuyến tĩnh là gì

Xem thêm: Collinearity Là Gì – Hiện Tượng Đa cùng Tuyến (Multicollinearity)

lúc đó người quản trị với chức năng cập nhật, xóa bỏ những thông tin về đường đi cho router.

II. Đặc điểm:

– Áp dụng cho môi trường mạng nhỏ (khoảng dưới 5 router)

– ko tiêu tốn đường dẫn đường truyền để những thông báo giữa những Router về những đường đi

– ko tiêu tốn tài nguyên của hệ thống Router tính toán đường đi như định tuyến động

– Bảo mật vì Router chỉ hoạt động dựa vào những đường đi mà Admin chỉ định

– Rất khó khắc phục sự cố, phải cấu hình lại lúc với sự thay đổi về địa chỉ mạng cũng như những thiết bị

III. Cấu hình

– lần thứ nhất ta vào cấu hình IP cho 2 router

Tại Router0

Router>en

Router#conf t

Router(config)#hostname Router0

Router0(config)#interface f0/0

Router0(config-if)#ip address 10.0.0.một 255.255.255.0

Router0(config-if)#no shutdown

Router0(config-if)#exit

Router0(config)#interface f0/một

Router0(config-if)#ip address 192.168.một.một 255.255.255.0

Router0(config-if)#no shutdown

Tại Router1

Router>en

Router#conf t

Router(config)#hostname Router1

Router0(config)#interface f0/0

Router0(config-if)#ip address 10.0.0.2 255.255.255.0

Router0(config-if)#no shutdown

Router0(config-if)#exit

Router0(config)#interface f0/một

Router0(config-if)#ip address 172.16.một.một 255.255.255.0

Router0(config-if)#no shutdown

– Để kích hoạt định tuyến tĩnh chúng ta với 2 cách cấu hình sau:

Cách một:

Router(config)#ip route

Hoặc cách 2:

Router(config)#ip route

Ví dụ ta với mô hình sau:

Hình một: Mô hình mạng sử dụng cấu hình Static

Cách một: Router(config)#ip route

+ Network: địa chỉ Network của những IP trong mạng (ví dụ trên network =172.16.một.0

+ Nexthop: Là ip của cổng của Router kế tiếp trên đường đi tới network đích của packet

Tại Router0 , Network đích là 172.16.một.0 Subnet Mask 255.255.255.0; để sang được network này Router0 phải đi qua cổng F0/0 của Router1, mà cổng IP này với địa chỉ IP=10.0.0.một. Vậy cách một chúng ta với lệnh

Router0>en

Router0#conf t

Router0(config)#ip route 172.16.một.0 255.255.255.0 10.0.0.một

Tương tự như vậy trên Router1 muốn gửi packet tới network đích là 192.168.một.0 subnet mask 255.255.255.0 thì phải đi qua cổng nexthop là f0/0 của Router0 (mà IP của cổng này là 10.0.0.2)

Vậy trên Router1 ta với cấu hình:

Router1>en

Router1#conf t

Router1(config)#ip route 192.168.một.0 255.255.255.0 10.0.0.2

Note: Ta phải cấu hình trên tất cả những Router thì mới Ping thấy nhau vì gói tin phải được định tuyến đi và về (gửi và nhận)

Tại những PC ta đặt IP cho những máy theo thứ tự như hình một

Cách 2: Router(config)#ip route

+ Exit Interface: Tên cổng thoát ra của Packet tại router được cấu hình ví dụ f0/0, s0/0

Trên Router0 muốn sang network đích thì gói tin sẽ được thoát ra từ cổng F0/0 chứ ko phải f0/một của Router này, nên ta với lệnh:

Router0(config)#ip route 172.16.một.0 255.255.255.0 f0/0

Tương tự ta với lệnh trên Router1:

Router0(config)#ip route 172.16.một.0 255.255.255.0 f0/0

Kết quả:

Với những PC và những cổng của Router đặt như trên hình ta với thể Ping từ PC0 tới tất cả những PC khác trong LAN

lưu ý: Với cách 2 trên ta ko thể cấu hình trên môi trường mạng Multi Access như sau:

*

Hình 2: Mô hình mạng trong môi trường đa truy nhập (Multi Access)

Vì nếu Router0 muốn sang network đích là 172.16.một.0 mà cứ thoát ra khỏi cổng f0/0 trên Router0 thì packet đó ra tới Switch ko thể biết là qua Router1 hay Router2 đây.

Lượt xem (21735)

Xem thêm: Erg Là Gì

Cấu hình định tuyến mặc định (Default Route) p2 Configuring Static Route Định tuyến những Vlan và cài đặt DHCP

*

Định tuyến trên Router (phần 2) Default route

*

CCNA#một – Định tuyến căn bản VLAN routing by Sub Interface on the Router

*

Process routing on a Router

Chuyên mục: Hỏi Đáp


Nguồn : Sưu tầm

Related Articles

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *

Back to top button